[PHP-users 9972] PHPからのDBリモートアクセス
php-users@php.gr.jp
php-users@php.gr.jp
Wed, 11 Sep 2002 11:23:27 +0900
始めまして、雨宮と申します。PHPからのDBへの接続について質問させてください。マシンAから、PHPでマシンBのDBにアクセスする際に下記のようなエラーが出ています。なにぶん初心者なのもで、検索しても対策などが発見できないで、どなたか教えてください。因みにマシンBのPostgresは正常に動作しいます。"-i"オプションでの起動ですし、pg_hba.confにもアクセス許可を与えています。◇エラーメッセージ◇Warning: pg_connect() unable to connect to PostgreSQL server: connectDBStart() -- connect() failed: Invalid argument Is the postmaster running (with -i) at 'マシンB' and accepting connections on TCP/IP port '5432'? in /public/htdocs/phptest.php on line 21It failed to the implementation◇エラーメッセージ◇マシンAOS:HP-UX11.00DB:Postgres7.0.2(PHPのコンパイル用で使用はしません)PHP:php4.2.2マシンBOS:TurboLinux6.5JDB:Postgres7.0.2PHP:php3.0.18-i18n-ja-2です。別のマシン(OSはTurbo7)から、マシンBへ��PHP4.0.6でアクセスしたところ、DBへ接続出来ています。(プログラムは全く同じものを使用していて、至極簡単なものです)プログラムは下記の通りです。<?phpecho "";$host = "マシンB";$port = "5432";$db_name = "testdb";$conn_id = pg_connect( "host=$host user=$user dbname=$db_name" );if( !$conn_id ){ echo "It failed to the implementation
\n"; exit;}echo "con_id=$conn_id
";echo "";?>長々とすいませんが、どなたか有識者の方がいたら教えて頂きたいのですが、お願いします。---------------------------雨宮 薫Amemiya kaorue-mail:k_all@infoseek.jp------------------------------------------------------------------------★《広告》が消える!?!? それが、有料メーリングリスト by infoseek http://sml.www.infoseek.co.jp/?svx=971148